ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น

ThaiSEOBoard.comพัฒนาเว็บไซต์CMS & Free ScriptSMF เข้าหน้าแรกและตั้งกระทู้ใหม่กับตอบกระทู้ไม่ได้
หน้า: [1]   ลงล่าง
พิมพ์
ผู้เขียน หัวข้อ: SMF เข้าหน้าแรกและตั้งกระทู้ใหม่กับตอบกระทู้ไม่ได้  (อ่าน 2076 ครั้ง)
0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้
scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« เมื่อ: 16 สิงหาคม 2022, 10:51:13 »

ปัญหา SMF เข้าหน้าแรกและตั้งกระทู้ใหม่กับตอบกระทู้ไม่ได้ครับ
-เป็นเว็บบอร์ดที่ทำงาน  http://www.scdc5.forensic.police.go.th/forum/index.php
- ใช้  SMF 1.1.11  ใช้งานมาได้ตามปกติตั้งแต่ ปี 2013 ปัญหาเกิดขึ้นเมื่อเดือน ก.ค. 2565   ได้มีการปรับปรุงระบบฐานข้อมูล ส่งผลให้ข้อมูลของที่ทำงานเสียหายแจ้งว่า กู้คืนไม่ได้
   แต่ที่ทำงานได้มีการ export จากระบบไว้เดือน ม.ค. 2565 ได้เป็น ไฟล์ .sql  ต่อมาได้มีการ import โดยใช้โปรแกรม bigdump ได้เรียบร้อย มีการตรวจสอบพาทของธีม และcharset    SMF ที่ใช้งาน มี 3 ธีม คือ ธีม SMF มาตราฐาน, ธีม YaBB SE คลาสสิค และ ธีม Babylon ซึ่งที่ผ่านมาได้ใช้ธีม YaBB SE คลาสสิค ตลอดมา
- ปัญหาที่เกิดขึ้น มี 2 ปัญหาครับ

   1. เว็บบอร์ดเข้าใช้งานได้หน้าปกติ แต่ ไม่สามารถตั้งหัวข้อใหม่และตอบกระทู้ได้ ได้มีแก้เอาไฟล์เดิมหลายไฟล์มาลองใช้ผ่าน FTP  แก้ไปมา แต่ก็ไม่ได้ มีการลบฐานข้อมูลและอิมพอร์ต ใหม่อยู่หลายครั้ง แต่ก็ยังแก้ไขไม่ได้


   2. จากปัญหาที่ 1  ส่งผลตามมาหลังจากได้ทำไปแล้ว หลายครั้ง  ผลคือ ตอนนี้เข้าหน้าหลักคือ http://www.scdc5.forensic.police.go.th/forum/index.php ไม่ได้ เป็นหน้าขาวหมด แม้จะลบและอิมพอร์ตฐานข้อมูลใหม่  แต่หน้าอื่นเข้าได้ปกติ แต่ต้องไปเข้าหน้าเว็บหลักของที่ทำงานซึ่งได้มีการเอากระทู้ไปแสดงหน้าหลักเว็บไซต์  เข้าไปจัดการของแอดมินได้  สุดท้ายไปดูการแก้ไขการอนญาต พบมีการอนุญาตให้ตั้งกระทู้ใหม่และตอบกระทู้ของสมาชิกอยู่

  -ผมจึงขอความช่วยเหลือในการแก้ปัญหานี้ให้สามารถใช้งานได้ปกติ   เนื่องจากเว็บบอร์ดมีความจำเป็นต้องใช้งานและไม่ได้มีการงานมาหลายวันแล้วครับ / ขอบคุณครับ
« แก้ไขครั้งสุดท้าย: 16 สิงหาคม 2022, 12:42:53 โดย scpol » บันทึกการเข้า

CONY
คนรักเสียว
*

พลังน้ำใจ: 17
ออฟไลน์ ออฟไลน์

กระทู้: 171



ดูรายละเอียด
« ตอบ #1 เมื่อ: 16 สิงหาคม 2022, 14:24:03 »

แนะนำให้อัพเกรดฐานข้อมูลไปใช้ SMF 2.1 ครับ
บันทึกการเข้า
scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #2 เมื่อ: 16 สิงหาคม 2022, 15:01:24 »

แนะนำให้อัพเกรดฐานข้อมูลไปใช้ SMF 2.1 ครับ

ผมยังไม่ค่อยถนัดในการอัพเกรด แต่อาจเป็นทางเลือกหนึ่ง ถ้าไม่ได้จริงๆ ขอบคุณครับ
บันทึกการเข้า

TG_Min
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 146
ออฟไลน์ ออฟไลน์

กระทู้: 1,368



ดูรายละเอียด เว็บไซต์
« ตอบ #3 เมื่อ: 16 สิงหาคม 2022, 15:48:49 »

เป็นที่ theme ครับ ไม่ใช่เป็นที่ฐานข้อมูล เพราะไปแก้ไม่ถูกจุด

แนะนำให้ลอง ลบ theme เดิมไปใช้ theme มาตรฐานก่อน

เมื่อได้แล้วค่อยไป import theme เข้าไปใหม่ แบบโหลดต้นฉบับมา install เลยไม่ใช่เอาของเก่ามายัดเข้าไป เพราะมันจะเป็นเหมือนเดิม

เดาว่า น่าจะเกิดจาก theme default มีปัญหากับการ update บางครั้งมันไม่ยอมรับ ต้องไปติดตั้งใหม่
บันทึกการเข้า

scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #4 เมื่อ: 16 สิงหาคม 2022, 19:05:12 »

เป็นที่ theme ครับ ไม่ใช่เป็นที่ฐานข้อมูล เพราะไปแก้ไม่ถูกจุด

แนะนำให้ลอง ลบ theme เดิมไปใช้ theme มาตรฐานก่อน

เมื่อได้แล้วค่อยไป import theme เข้าไปใหม่ แบบโหลดต้นฉบับมา install เลยไม่ใช่เอาของเก่ามายัดเข้าไป เพราะมันจะเป็นเหมือนเดิม

เดาว่า น่าจะเกิดจาก theme default มีปัญหากับการ update บางครั้งมันไม่ยอมรับ ต้องไปติดตั้งใหม่

ขอบคุณในคำแนะนำ จะพยายามทำตามครับ
บันทึกการเข้า

scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #5 เมื่อ: 23 สิงหาคม 2022, 16:45:03 »

ความคืบหน้าการแก้ไขปัญหาครับ

1. หน้า index.php `กลับมาเป็นปกติแล้ว แก้ไปมาเลยไม่แน่ใจว่าเกิดจากอะไร
2. ได้ทำตามที่คุณ TG_Min แนะนำมาแล้วยังไม่ได้
3. ลองอัพเกรด เป็น v 1.1.21 แล้วยังแก้ปัญหาไม่ได้
4. ลองอัพเกรดเป็น v.2.0.19 ตามที่คุณ CONY แนะนำไม่ผ่านขั้นตอน database chang


5. ได้ตรวจสอบกับ repair_settings.php พบข้อความซึ่งได้มาโฟกัสทีหลังคือ
Cache Settings
These are the cache settings to your SMF installation, and can cause big problems when they are wrong.

-ลองไปค้นหาวิธีทางลบแคช ใน SMF ไม่มีให้ลบ และไปไปดูใน FTP ไม่มีโฟลเดอร์ Cach
-ปัญหาใหญ่ที่คาดว่าเป็นไปได้มากที่สุดคือ แคช แต่ยังหาวิธีจัดการไม่ได้ครับ  wanwan044
บันทึกการเข้า

TG_Min
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 146
ออฟไลน์ ออฟไลน์

กระทู้: 1,368



ดูรายละเอียด เว็บไซต์
« ตอบ #6 เมื่อ: 24 สิงหาคม 2022, 09:06:30 »

หน้า admin เข้าเมนู Maintenance ได้ไหมครับ
ลองกดซ่อมแซมในปุ่มสีแดง ของแท๊บ routine ดู เผื่อจะหาย
ในส่วนนี้ มีให้ลบ cache ด้วย

ถ้าจะลบ cache เองใน host ผมไม่แนะนำ

ตอนนี้ภาษายังอ่านไม่ได้นะครับ คงยังไม่ได้ไปตั้งค่าให้เป็น UTF-8

เท่าที่เช็คคร่าว ๆ น่าจะพังเพราะไฟล์ต่าง version กัน

ลองสร้าง subdomain มาทดสอบ แล้ว setup smf ให้ครบ
แล้วเปลี่ยนข้อมูลใน setting ให้ดึงฐานข้อมูลเดิมมาใช้

ถ้าพัง แสดงว่าไม่เกี่ยวกับไฟล์ แต่เกี่ยวกับฐานข้อมูล
แต่ถ้าเปิดได้ แสดงว่า เกี่ยวกับไฟล์ที่ต่าง version กัน

ไม่ว่าจะพังด้วยอะไร จะต้องไป optimize มันให้เป็น version ที่ใช้งาน ถึงจะได้ผล

ปกติเวลา update ไฟล์ที่จะถูกแก้อัตโนมัติคือ index , setting แต่บางทีมันไป error ในไฟล์ SSI ด้วย ทดสอบด้วยการเปิดไฟล์ domain/ssi_examples.php แล้ว ก็ใช้ได้

ปัญหาหลัก อย่างที่ยืนยัน น่าจะเป็นที่ theme ไม่ก็ใน SSI ที่ต่าง version กัน
บันทึกการเข้า

scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #7 เมื่อ: 24 สิงหาคม 2022, 09:44:59 »

หน้า admin เข้าเมนู Maintenance ได้ไหมครับ
ลองกดซ่อมแซมในปุ่มสีแดง ของแท๊บ routine ดู เผื่อจะหาย
ในส่วนนี้ มีให้ลบ cache ด้วย

ถ้าจะลบ cache เองใน host ผมไม่แนะนำ

ตอนนี้ภาษายังอ่านไม่ได้นะครับ คงยังไม่ได้ไปตั้งค่าให้เป็น UTF-8

เท่าที่เช็คคร่าว ๆ น่าจะพังเพราะไฟล์ต่าง version กัน

ลองสร้าง subdomain มาทดสอบ แล้ว setup smf ให้ครบ
แล้วเปลี่ยนข้อมูลใน setting ให้ดึงฐานข้อมูลเดิมมาใช้

ถ้าพัง แสดงว่าไม่เกี่ยวกับไฟล์ แต่เกี่ยวกับฐานข้อมูล
แต่ถ้าเปิดได้ แสดงว่า เกี่ยวกับไฟล์ที่ต่าง version กัน

ไม่ว่าจะพังด้วยอะไร จะต้องไป optimize มันให้เป็น version ที่ใช้งาน ถึงจะได้ผล

ปกติเวลา update ไฟล์ที่จะถูกแก้อัตโนมัติคือ index , setting แต่บางทีมันไป error ในไฟล์ SSI ด้วย ทดสอบด้วยการเปิดไฟล์ domain/ssi_examples.php แล้ว ก็ใช้ได้

ปัญหาหลัก อย่างที่ยืนยัน น่าจะเป็นที่ theme ไม่ก็ใน SSI ที่ต่าง version กัน

ขอบคุณในคำแนะนำมากครับ จะพยายามทำตามที่แนะนำ    สำหรับภาษา ผมได้ไปปรับ ใน repair_settings.php ให้เป็นthai ปกติแล้วครับ  ภาษาบอร์ดถูกสร้างเป็น tis-620 เคยลองเปลี่ยน utf8 ใน SMF แล้วไม่ได้   และเคย export ให้เป็น utf8  แล้ว มาเปิดใช้งานก็เป็นภาษาต่างด้าวหมด  เลยต้องใช้ tis-620  ตามเดิม   เมนู Maintenance เข้าได้ แต่ไม่แท๊บ routine  มีแต่แท็ป caching 





บันทึกการเข้า

CONY
คนรักเสียว
*

พลังน้ำใจ: 17
ออฟไลน์ ออฟไลน์

กระทู้: 171



ดูรายละเอียด
« ตอบ #8 เมื่อ: 26 สิงหาคม 2022, 13:57:56 »

ใช้ php v ไหนครับ
บันทึกการเข้า
scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #9 เมื่อ: 26 สิงหาคม 2022, 16:26:12 »

ใช้ php v ไหนครับ

PHP version: 5.6.18 ดูจาก phpmyadmin ไม่ทราบว่าถูกต้องหรือเปล่าครับ





« แก้ไขครั้งสุดท้าย: 26 สิงหาคม 2022, 16:39:30 โดย scpol » บันทึกการเข้า

scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #10 เมื่อ: 27 สิงหาคม 2022, 12:18:05 »

 
ตอนนี้ผมได้เข้าตรวจดู SSI.php กับ ssi_examples.php ภาษาไม่เป็นภาษาไทย ไปลองปรับแก้ใน ไฟล์ setting.php,  ssi_examples.php,  index.template.php ,ssi_examples.shtml
โดยแก้ให้เป็น UTF-8 แล้วยังไม่ได้  และเข้าดู Sources code ได้ผลเป็น <meta http-equiv="Content-Type" content="text/html; charset=utf-8tis-620" /> เลยต้องเอา UTF-8 ออกจึงกลับมาเป็น <meta http-equiv="Content-Type" content="text/html; charset=tis-620" />  
ต้องแก้ปัญหาภาษาตรงไหนครับ









« แก้ไขครั้งสุดท้าย: 27 สิงหาคม 2022, 12:18:40 โดย scpol » บันทึกการเข้า

watyai
สมุนแก๊งเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 557



ดูรายละเอียด เว็บไซต์
« ตอบ #11 เมื่อ: 27 สิงหาคม 2022, 13:02:47 »

ใช้ encoding ให้เหมือนกันทั้งหน้าเว็บและฐานข้อมูล และ ตอนแก้ไขหรือปรับแต่ง แนะนำให้ปิด cache ไม่งั้นจะสับสนกับข้อมูลที่ออกมาว่ามันเอาจาก cache หรือจากฐานข้อมูลจริงๆ
จากที่เล่ามาฐานข้อมูลน่าจะเก่ามาก แปลงเป็น utf-8 ก่อน
แล้วค่อยแก้ปัญหาเรื่องอื่นๆ ต่อ
ดูแล้วปัญหาซ้อนปัญหาอยู่หลายอย่างนะครับ ค่อยๆ แก้ไปทีละจุด หรือหาผู้เชียวชาญ ช่วย

หรือแปลงมาเป็น phpBB3 จะมีตัวช่วยแปลงฐานข้อมูลอยู่ครับ 
บันทึกการเข้า

Component Joomla สร้างฟอร์ม แค่ลากวาง มีใครทำเว็บขายของด้วย MooZiiCart กันบ้าง
scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #12 เมื่อ: 27 สิงหาคม 2022, 14:05:13 »

ใช้ encoding ให้เหมือนกันทั้งหน้าเว็บและฐานข้อมูล และ ตอนแก้ไขหรือปรับแต่ง แนะนำให้ปิด cache ไม่งั้นจะสับสนกับข้อมูลที่ออกมาว่ามันเอาจาก cache หรือจากฐานข้อมูลจริงๆ
จากที่เล่ามาฐานข้อมูลน่าจะเก่ามาก แปลงเป็น utf-8 ก่อน
แล้วค่อยแก้ปัญหาเรื่องอื่นๆ ต่อ
ดูแล้วปัญหาซ้อนปัญหาอยู่หลายอย่างนะครับ ค่อยๆ แก้ไปทีละจุด หรือหาผู้เชียวชาญ ช่วย

หรือแปลงมาเป็น phpBB3 จะมีตัวช่วยแปลงฐานข้อมูลอยู่ครับ 

ขอบคุณมากครับ
บันทึกการเข้า

scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #13 เมื่อ: 31 สิงหาคม 2022, 20:33:51 »

ตอนนี้ที่ผมสามารถทำได้จากที่สมาชิกแนะนำมา ก็คือ

1. เปลี่ยนฐานข้อมูล จาก tis620 เป็น  utf8 ได้แล้ว และไป encoding ไฟล์ .php (ไม่ทราบว่าต้องทุกไฟล์ทั้งหมดหรือเปล่า เช่น .css   จาก ANSI เป็น  UTF8
2. เมื่ออัพโหลดไฟล์ที่แก้ไข ไปแล้ว ผลหน้าบอร์ดเป็นภาษาต่างดาวหมด เลยล๊อกอินเข้าไปคลิกสุ่มหาแทป ผู้ดูแล และไปหา บำรุงรักษา ซึ่งจำตำแหน่งได้ หาดูเจอ UTF8
  ซึ่งเมื่อก่อนเคยแปลงแล้วไม่ผ่าน จึงคลิกเลือก UTF8 กดไป ผลปรากฎว่า เป็นภาษาไทยทั้งหมดในหน้าของผู้ดูแล  




 แต่ไปดูในหน้าแรก   http://www.scdc5.forensic.police.go.th/forum/index.php



  ปรากฎภาษาไทย ซึ่งคิดว่าน่าจะเป็นส่วนของ index.template.php ส่วนตรงที่ เป็นหัวข้อกระทู้ขาวหมด
   - ภาษาแก้ ใน smf จาก thai เป็น thai-utf8 และดูใน settings.php ถูกเปลี่ยนแล้ว
   ลองค้นหาดูวิธีและพยายามแก้ ยังไม่ได้  ไม่รู้ต้องไปจุดไหนครับ



ตอนนี้อยู่ๆ มาดูอีกทีเป็นแบบนี้แล้วครับ ไม่ได้ไปแก้ load.php  ค้นหาดูเขาแก้ปัญหาด้วยการอัพเกรด (ลองแล้วไม่ผ่าน) กลับมาใช้ไฟล์แบ็คอัพครับ



« แก้ไขครั้งสุดท้าย: 01 กันยายน 2022, 11:57:40 โดย scpol » บันทึกการเข้า

CONY
คนรักเสียว
*

พลังน้ำใจ: 17
ออฟไลน์ ออฟไลน์

กระทู้: 171



ดูรายละเอียด
« ตอบ #14 เมื่อ: 02 กันยายน 2022, 00:37:17 »

คงต้องแก้ปัญหาเรื่อง convert to utf8 ก่อนครับ ปัญหาบอร์ดค่อนข้างซับซ้อน
พอ convert แล้วข้อมูลใน database เป็นภาษาไทยปกติ แล้วค่อยอัพเกรด
อาจจะต้องอัพเป็นขั้นเช่นจาก 1.1.21 --> 2.0 --> 2.0.1 ไปจนถึง 2.0.19
อย่าอัพข้ามขั้น ปัญหาไม่ได้ยากเกินไปครับ แต่ต้องใช้เวลาหน่อย โดยเฉพาะ forum ที่มีจำนวนกระทู้มาก ๆ
(ผมเคย convert to utf8 แล้วอัพเกรดข้อมูล ตอนนั้น forum ที่ทำมีประมาณ 5 แสนกระทู้ได้)
บันทึกการเข้า
scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #15 เมื่อ: 02 กันยายน 2022, 09:25:50 »

คงต้องแก้ปัญหาเรื่อง convert to utf8 ก่อนครับ ปัญหาบอร์ดค่อนข้างซับซ้อน
พอ convert แล้วข้อมูลใน database เป็นภาษาไทยปกติ แล้วค่อยอัพเกรด
อาจจะต้องอัพเป็นขั้นเช่นจาก 1.1.21 --> 2.0 --> 2.0.1 ไปจนถึง 2.0.19
อย่าอัพข้ามขั้น ปัญหาไม่ได้ยากเกินไปครับ แต่ต้องใช้เวลาหน่อย โดยเฉพาะ forum ที่มีจำนวนกระทู้มาก ๆ
(ผมเคย convert to utf8 แล้วอัพเกรดข้อมูล ตอนนั้น forum ที่ทำมีประมาณ 5 แสนกระทู้ได้)

ขอบคุณครับ ฐานข้อมูล ผมได้เปลี่ยนเป็น utf8  แล้วแต่มาตรวจดูภาษาไทยยังไม่เห็น จะไล่ตรวจแก้ดูใหม่ และทำตามคำแนะนำครับ
บันทึกการเข้า

scpol
คนรักเสียว
*

พลังน้ำใจ: 10
ออฟไลน์ ออฟไลน์

กระทู้: 147



ดูรายละเอียด เว็บไซต์
« ตอบ #16 เมื่อ: 14 กันยายน 2022, 09:45:42 »

- ตอนนี้ เว็บบอร์ดของหน่วยงานใช้งานได้แล้ว โดยให้เจ้าหน้าที่ที่ทำงานซึ่งมีความรู้ทางคอมพิวเตอร์ มาศึกษา smf รวมทั้งที่สมาชิกแนะนำในกระทู้นี้  ได้หาวิธีแก้ไขแบบลองผิดลองถูก  สุดท้ายของการแก้ไขที่ทราบมา คือ  การเข้าไปทำใน localhost   โดยได้อัพเกรดมาเป็น เวอร์ชั่น 2.0.19   แล้ว export  แล้วนำมา import ที่  Host จริง ซึ่งใช้งานได้ แต่ยังไม่สมบูรณ์ 100 %  แต่สามารถใช้งานที่ต้องการตามปกติได้
 
- ขอบคุณทุกคำแนะนำอีกครั้งครับ wanwan017
           
บันทึกการเข้า

Dewmetee
Newbie
*

พลังน้ำใจ: 1
ออฟไลน์ ออฟไลน์

กระทู้: 28



ดูรายละเอียด
« ตอบ #17 เมื่อ: 14 กันยายน 2022, 18:40:00 »

ขอบคุณครับผม  wanwan017
บันทึกการเข้า
หน้า: [1]   ขึ้นบน
พิมพ์