ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น

ThaiSEOBoard.comพัฒนาเว็บไซต์CMS & Free Scriptsmf ผมติดปัญหานี้แก้อย่างไรครับ
หน้า: [1]   ลงล่าง
พิมพ์
ผู้เขียน หัวข้อ: smf ผมติดปัญหานี้แก้อย่างไรครับ  (อ่าน 561 ครั้ง)
0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้
nitikon101
Newbie
*

พลังน้ำใจ: 1
ออฟไลน์ ออฟไลน์

กระทู้: 47



ดูรายละเอียด
« เมื่อ: 29 สิงหาคม 2020, 20:10:53 »

  ขึ้น   Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /

smf ผมเป็นเวอร์ชั่นเก่า 1.1.16    php โฮสผม เวอร์ชั่น Current PHP version: 5.6.30

ลองดูที่ http://www.nitikon.com/va16/index.php
บันทึกการเข้า
musichost
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 214
ออฟไลน์ ออฟไลน์

กระทู้: 1,796



ดูรายละเอียด เว็บไซต์
« ตอบ #1 เมื่อ: 30 สิงหาคม 2020, 00:35:47 »

smf 1.1.16 ตัวเก่า น่าจะรันได้บน php 5.3 หรือเปล่าไม่ค่อยแน่ใจ แต่ตามที่ขึ้นน่าจะต้องหาวิธีแก้ที่ไฟล์ Load.php   wanwan044


https://www.simplemachines.org...unity/index.php?topic=506431.0

https://www.simplemachines.org...unity/index.php?topic=559655.0
บันทึกการเข้า

iCafe
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 123
ออฟไลน์ ออฟไลน์

กระทู้: 1,813



ดูรายละเอียด เว็บไซต์
« ตอบ #2 เมื่อ: 30 สิงหาคม 2020, 09:33:33 »

มันเออเร่อที่ตัว smf ครับพอดีพึ่งเปิดคอมดู ตามท่านล่างๆเลยครับ
« แก้ไขครั้งสุดท้าย: 30 สิงหาคม 2020, 13:39:27 โดย iCafe » บันทึกการเข้า

rathasat2012
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 167
ออฟไลน์ ออฟไลน์

กระทู้: 1,381



ดูรายละเอียด เว็บไซต์
« ตอบ #3 เมื่อ: 30 สิงหาคม 2020, 10:07:16 »

เป็นที่ SMF ครับ ให้แก้ไล่ทีละไฟล์ที่ระบบ แจ้งครับ อาทิแจ้ง laod ก็ดูว่ามีเออเร่อบันทัดไหนมันจะแจ้งหมด วิธีที่ดีที่สุด อัพไฟล์ตัวใหม่แทนได้ครับ แต่บางครั้งถ้าเราใช้สคริปต์ซึ่งเก่ามากไม่มีการอัพเดทมา หลายปีแล้วเหมือนสคริปต์ที่คุณติดตั้งเกิดจากระบบฐานข้อมูลครับ ต้องหาโฮสที่รองรับ หรือตั้งค่า PHP เป็น5.3 หรือ 5.6 ถ้ายังไม่ได้ให้ อัพเดท SMF เป็นเวอร์ชั่นล่าสุดครับ ถ้าอยากใช้เดิมๆที่คุณติดตั้งต้องหาโฮสที่รองรับครับ ซึ่งน่าจะยากอยู่เพราะโฮสเขาก็ต้องปรับตัวให้เข้ากับยุคสมัย แต่อย่างน้อยเขาก็ยังมีให้เลือก php หลายเวอร์ชั่นอยู่ยังพอประคองสคริปต์เก่าๆได้บ้าง แต่ส่วนมากสคริปต์เมื่อ 10 ปีก่อนถ้ามีการใช้ Session ปัจจุบันจะใช้งานไม่ได้เลยลองสังเกตุเว็บหลายๆท่าน อาทิร้านค้าออนไลน์ หรืออื่นๆจะเห็นเออเร่อหลายเจ้าอยู่ สืบเนื่องเพราะโฮสเขาไม่ค่อยเปิดให้ใช้งานแล้วครับ ต้องปรับใช้คุ๊กกี้แทน พูดง่ายๆคือถ้าเป็นไปได้ต้องรื้อเขียนใหม่บางส่วนครับ Sql เหมือนกันสคริปต์เมื่อ 10 ปีก่อนไม่เหมาะมาใช้ในปัจจุบันครับ ต้องศัลยกรรมสคริปต์ก่อนถึงจะใช้งานได้ดีเช่นเดิม ไม่งั้นมันจะขาดๆเกินๆ น่าจะประมาณนี้นะ
บันทึกการเข้า

ขายเว็บไซต์.com
JeffyPluS
Verified Seller
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 236
ออฟไลน์ ออฟไลน์

กระทู้: 3,100



ดูรายละเอียด เว็บไซต์
« ตอบ #4 เมื่อ: 30 สิงหาคม 2020, 10:37:26 »

Deprecated คือเลิกใช้แล้ว
error นี้ คือมีการยกเลิกคำสั่ง ใน php versions ที่ใช้แล้ว ต้องไปใช้คำสั่งทดแทน

ถ้าไม่ถนัดในการแก้ไข code ง่ายสุด ก็ต้อง อัพเดท smf เป็น versions ใหม่ครับ หรือ โฮสที่รองรับ php versions เก่า

ปล.ถ้ามีการแก้ไข code แบบ manual เวลาอัพเดท versions จะใช้ระบบทำแบบอัตโนมัติ ไม่ได้นะครับ ต้อง manual ตลอดเลย หรือต้องแก้ไขกลับให้เป็นแบบเดิมก่อน หรือต้อง ใช้ไฟล์อัพเกรดจาก smf ซึ่งจะส่งผลต่อ mod mี่ติดตั้งไว้ครับ

« แก้ไขครั้งสุดท้าย: 30 สิงหาคม 2020, 10:39:42 โดย JeffyPluS » บันทึกการเข้า


เว็บโฮสติ้ง แรง เร็ว เสถียร พร้อมดูแลทุกท่านคุณภาพการบริการเริ่มต้นเพียง 500.-/ปี
█ Tel 0810066690 | EVO VPS | EVO Hosting
VPS Hosting ประสิทธิภาพสูง แรง เร็ว เสถียร
FB : evohostinginth
chezterarm
คนรักเสียว
*

พลังน้ำใจ: 2
ออฟไลน์ ออฟไลน์

กระทู้: 132



ดูรายละเอียด เว็บไซต์
« ตอบ #5 เมื่อ: 30 สิงหาคม 2020, 11:03:44 »

รอด้วยคน
บันทึกการเข้า

7one011
ก๊วนเสียว
*

พลังน้ำใจ: 3
ออฟไลน์ ออฟไลน์

กระทู้: 211



ดูรายละเอียด เว็บไซต์
« ตอบ #6 เมื่อ: 30 สิงหาคม 2020, 11:28:05 »

Deprecated คือเลิกใช้แล้ว
error นี้ คือมีการยกเลิกคำสั่ง ใน php versions ที่ใช้แล้ว ต้องไปใช้คำสั่งทดแทน
บันทึกการเข้า

nitikon101
Newbie
*

พลังน้ำใจ: 1
ออฟไลน์ ออฟไลน์

กระทู้: 47



ดูรายละเอียด
« ตอบ #7 เมื่อ: 31 สิงหาคม 2020, 09:29:09 »

ขอบพระคุณทุกท่านที่กรุณา ให้คำตอบ จะพยายามแก้ครับ   ไม่สามารถอัพได้  ถ้าอัพเวอร์ชั่น smf  บอร์ดเละเลยครับ  เพราะผมไม่ค่อยมีความรู้ โค๊ดเท่าไหร่  ธีมนี้ซื้อมานานแล้ว ยังพอใช้ได้ กับ พีเอชพี 5.   แต่ใช้กับ 7. ไม่ได้เลย  เนื่องจากตอนนี้ ไม่มีใคร โม smf ขายแล้ว  อยากได้วาไรตี้ 2.0.17  เคยเอา  ตัวนี้มา มั่วๆ  ใน 2.0.17  เละตุ้มเป๊ะ  ไม่มีความรู้โค๊ด  แก้ไม่ได้
บันทึกการเข้า
rathasat2012
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 167
ออฟไลน์ ออฟไลน์

กระทู้: 1,381



ดูรายละเอียด เว็บไซต์
« ตอบ #8 เมื่อ: 31 สิงหาคม 2020, 09:43:37 »

ขอบพระคุณทุกท่านที่กรุณา ให้คำตอบ จะพยายามแก้ครับ   ไม่สามารถอัพได้  ถ้าอัพเวอร์ชั่น smf  บอร์ดเละเลยครับ  เพราะผมไม่ค่อยมีความรู้ โค๊ดเท่าไหร่  ธีมนี้ซื้อมานานแล้ว ยังพอใช้ได้ กับ พีเอชพี 5.   แต่ใช้กับ 7. ไม่ได้เลย  เนื่องจากตอนนี้ ไม่มีใคร โม smf ขายแล้ว  อยากได้วาไรตี้ 2.0.17  เคยเอา  ตัวนี้มา มั่วๆ  ใน 2.0.17  เละตุ้มเป๊ะ  ไม่มีความรู้โค๊ด  แก้ไม่ได้
ปรึกษาได้ครับ การโม SMF 2.0.17
https://shoppingweb2u.com/index.php/board,326.0.html
บันทึกการเข้า

ขายเว็บไซต์.com
หน้า: [1]   ขึ้นบน
พิมพ์