ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น

ThaiSEOBoard.comพัฒนาเว็บไซต์CMS & Free Scriptผมย้ายserver SMF2.0.10 จาก PHP5.6 ไปที่ PHP7 มันพังเลยครับ The requested URL /u
หน้า: [1] 2   ลงล่าง
พิมพ์
ผู้เขียน หัวข้อ: ผมย้ายserver SMF2.0.10 จาก PHP5.6 ไปที่ PHP7 มันพังเลยครับ The requested URL /u  (อ่าน 1321 ครั้ง)
0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้
bosszi
คนรักเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 143



ดูรายละเอียด เว็บไซต์
« เมื่อ: 16 ธันวาคม 2018, 11:21:27 »

ผมย้ายserver SMF2.0.10 จาก PHP5.6 ไปที่ PHP7 มันพังเลยครับ
ทาง host แจ้งว่าให้เอาไปอัพเดทเป็นเวอร์ชั่นล่าสุดก่อนแล้วอัพขึ้นไปใหม่
ผมจึงอัพจากเครื่องผม SMF2.0.10 เป็นล่าสุด SMF2.0.15 ซึ่งที่เครื่องผมใช้งานได้ปรกติ
แต่พออัพขึ้นโฮส มัน error เหมือนเดิมครับ
Not Found
nginx/html/50x.html
ผมทดลองติดตั้ง  SMF2.0.15 ใหม่เลยก็เป็นเหมือนกันครับ
ผมต้องแก้อย่างไรครับ ขอบคุณสำหรับคำตอบครับ

http://www.star-circuit.com/webboard/index.php
บันทึกการเข้า

COW
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 95
ออฟไลน์ ออฟไลน์

กระทู้: 1,838



ดูรายละเอียด เว็บไซต์
« ตอบ #1 เมื่อ: 16 ธันวาคม 2018, 11:31:22 »

CHMOD values of 644, 664 or 666 for files, and 755, 775 or 777 for folders:

/attachments
/avatars
/Packages
/Packages/installed.list
/Smileys
/Themes
agreement.txt
Settings.php
Settings_bak.php
upgrade.php


ลองปรับ Permissions ก่อนครับ

เพราะเว็บบอร์ดท่านเข้าผ่าน html ได้แสดงว่าทำงานแล้ว
http://www.star-circuit.com/webboard/readme.html
บันทึกการเข้า

iCafe
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 121
ออฟไลน์ ออฟไลน์

กระทู้: 1,711



ดูรายละเอียด เว็บไซต์
« ตอบ #2 เมื่อ: 16 ธันวาคม 2018, 11:44:44 »

ผมย้ายserver SMF2.0.10 จาก PHP5.6 ไปที่ PHP7 มันพังเลยครับ
ทาง host แจ้งว่าให้เอาไปอัพเดทเป็นเวอร์ชั่นล่าสุดก่อนแล้วอัพขึ้นไปใหม่
ผมจึงอัพจากเครื่องผม SMF2.0.10 เป็นล่าสุด SMF2.0.15 ซึ่งที่เครื่องผมใช้งานได้ปรกติ
แต่พออัพขึ้นโฮส มัน error เหมือนเดิมครับ
Not Found
nginx/html/50x.html
ผมทดลองติดตั้ง  SMF2.0.15 ใหม่เลยก็เป็นเหมือนกันครับ
ผมต้องแก้อย่างไรครับ ขอบคุณสำหรับคำตอบครับ

http://www.star-circuit.com/webboard/index.php


หลังไมค์มาครับ รับแก้ไข

ปล ปัญหาคุ้นๆ
« แก้ไขครั้งสุดท้าย: 16 ธันวาคม 2018, 11:46:41 โดย iCafe » บันทึกการเข้า

บริการรับฝากซื้อ License Xenforo/vBulltin พร้อมติดตั่งพื้นฐาน ครับ

บริการรับฝากซื้อ License Directadmin พร้อมติดตั่งพื้นฐาน ครับ

โฮส ราคาถูก php5.4 - 5.6 - 7.1 - 7.2
bosszi
คนรักเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 143



ดูรายละเอียด เว็บไซต์
« ตอบ #3 เมื่อ: 16 ธันวาคม 2018, 11:56:38 »

ผมลองอัพเดทบนโฮสจริงถึงหน้าสุดท้าย กด your installation of SMF มันก็ขึ้นเหมือนเดิม
ทาง HOST แจ้งว่า จากการตรวจสอบตัว SMF น่าจะยังไม่รองรับ PHP 7.0 นะครับ จึงทำให้ไม่สามารถใช้งานได้ครับ
มันจริงไหมครับ  SMF ไม่รองรับ PHP 7.0 นะครับ


กด your installation of SMF มันก็ขึ้นเหมือนเดิม
« แก้ไขครั้งสุดท้าย: 16 ธันวาคม 2018, 12:00:08 โดย bosszi » บันทึกการเข้า

COW
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 95
ออฟไลน์ ออฟไลน์

กระทู้: 1,838



ดูรายละเอียด เว็บไซต์
« ตอบ #4 เมื่อ: 16 ธันวาคม 2018, 12:05:32 »

smf 2.0.15 + php 7.2 ใช้อยู่ครับ
บันทึกการเข้า

bosszi
คนรักเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 143



ดูรายละเอียด เว็บไซต์
« ตอบ #5 เมื่อ: 16 ธันวาคม 2018, 12:10:00 »

php 7.2 เช่า host ที่ไหนครับ ที่ผมย้ายเพราะต้อง เขียนโปรเจค Laravel ซึ่งต้องใช้ PHP >= 7.1.3
บันทึกการเข้า

iCafe
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 121
ออฟไลน์ ออฟไลน์

กระทู้: 1,711



ดูรายละเอียด เว็บไซต์
« ตอบ #6 เมื่อ: 16 ธันวาคม 2018, 12:13:50 »

https://smf2.icafezone.net

ใช้งานได้ปกติครับ
บันทึกการเข้า

บริการรับฝากซื้อ License Xenforo/vBulltin พร้อมติดตั่งพื้นฐาน ครับ

บริการรับฝากซื้อ License Directadmin พร้อมติดตั่งพื้นฐาน ครับ

โฮส ราคาถูก php5.4 - 5.6 - 7.1 - 7.2
bosszi
คนรักเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 143



ดูรายละเอียด เว็บไซต์
« ตอบ #7 เมื่อ: 16 ธันวาคม 2018, 12:21:48 »

ผมว่า ย้าย host ดีกว่า เพราะจะได้หา server ที่รองรับ PHP >= 7.1.3 ด้วยครับ
ท่านไหน เคยใช้อยู่ที่ไหนแนะนำด้วยครับ ขอบคุณครับ
บันทึกการเข้า

iCafe
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 121
ออฟไลน์ ออฟไลน์

กระทู้: 1,711



ดูรายละเอียด เว็บไซต์
« ตอบ #8 เมื่อ: 16 ธันวาคม 2018, 12:34:43 »

ผมว่า ย้าย host ดีกว่า เพราะจะได้หา server ที่รองรับ PHP >= 7.1.3 ด้วยครับ
ท่านไหน เคยใช้อยู่ที่ไหนแนะนำด้วยครับ ขอบคุณครับ

หลังไมค์ครับ คุยกันได้  wanwan011
บันทึกการเข้า

บริการรับฝากซื้อ License Xenforo/vBulltin พร้อมติดตั่งพื้นฐาน ครับ

บริการรับฝากซื้อ License Directadmin พร้อมติดตั่งพื้นฐาน ครับ

โฮส ราคาถูก php5.4 - 5.6 - 7.1 - 7.2
2DTH
ก๊วนเสียว
*

พลังน้ำใจ: 19
ออฟไลน์ ออฟไลน์

กระทู้: 470



ดูรายละเอียด เว็บไซต์
« ตอบ #9 เมื่อ: 16 ธันวาคม 2018, 12:38:12 »

บางทีอาจจะเป็นที่ permissions / htaccess ไม่ก็โฮสที่ใช้มันไม่รองรับอะไรหรือเปล่า...
#PHP7ใช้ได้ปกตินะครับ เข้าเว็บได้ แต่เปิดไม่ขึ้นแถมไม่ใช่ error ของ php น่าจะเป็นอย่างอื่นแล้วหล่ะผมว่า
#ความคิดเห็นมือใหม่ผิดพลาดประการใดขออภัยครับไม่ค่อยได้ใช้smf
บันทึกการเข้า

bosszi
คนรักเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 143



ดูรายละเอียด เว็บไซต์
« ตอบ #10 เมื่อ: 16 ธันวาคม 2018, 12:44:38 »

ผมลองเปลี่ยน permissions เป็น 777 หมดแล้วครับ ส่วน htaccess  ไม่รู้แก้ตรงไหนต้องแก้อย่างไร ขอบคุณครับ
บันทึกการเข้า

musichost
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 186
ออฟไลน์ ออฟไลน์

กระทู้: 1,536



ดูรายละเอียด เว็บไซต์
« ตอบ #11 เมื่อ: 16 ธันวาคม 2018, 13:29:31 »

SMF2.0.15 ลองติดตั้งบน php7.2 ได้ปกตินะคับ  http://coolhostplus.gq/1/

หรือ อาจจะเป้นที่โฮสเพราะมัน Not Found nginx/html/50x.html
« แก้ไขครั้งสุดท้าย: 16 ธันวาคม 2018, 13:42:34 โดย musichost » บันทึกการเข้า

BrainFreeze
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 494
ออฟไลน์ ออฟไลน์

กระทู้: 3,801



ดูรายละเอียด เว็บไซต์
« ตอบ #12 เมื่อ: 16 ธันวาคม 2018, 15:33:30 »

ผมเห็นข้อความแรกเขียนว่า ลองติดตั้งใหม่ก็ไม่ได้เหมือนกัน

งั้นลองแจ้งให้โฮสที่ใช้งานติดตั้ง SMF2.0.15 ให้ดูครับว่าได้มั้ย
เชื่อว่าถ้าท่านติดตั้งไม่ได้เจ้าของโฮสติดตั้งใหม่ดูก็จะพบปัญหา แล้วเดี๋ยวเค้าไล่ debug เองครับ

 wanwan017
บันทึกการเข้า

# จัดไป Promo Code ลด 11% : THAISEOBOARD
# hostatom.com |โฮสอะตอม - เว็บโฮสติ้งที่ Webmaster มืออาชีพไว้วางใจ
# Web Hosting | Cloud VPS | Reseller Hosting | Domain Name
# บริการ 24x7 | รับประกันความพอใจยินดีคืนเงิน | Uptime 99.9% | โทร : 0-2107-3466
CONY
คนรักเสียว
*

พลังน้ำใจ: 15
ออฟไลน์ ออฟไลน์

กระทู้: 157



ดูรายละเอียด
« ตอบ #13 เมื่อ: 16 ธันวาคม 2018, 21:28:41 »

ตอนนี้ใช้ SMF 2.0.15 กับ PHP 7.2 อยู่หลายไซต์ ไม่มีปัญหานะครับ
บันทึกการเข้า
JeffyPluS
Verified Seller
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 229
ออฟไลน์ ออฟไลน์

กระทู้: 3,014



ดูรายละเอียด เว็บไซต์
« ตอบ #14 เมื่อ: 17 ธันวาคม 2018, 08:23:03 »

ผมมีลูกค้า ใช้ smf กับ php 7.2 ก็ ไม่มีปัญหานะครับ
บันทึกการเข้า


เว็บโฮสติ้ง แรง เร็ว เสถียร พร้อมดูแลทุกท่านคุณภาพการบริการเริ่มต้นเพียง 500.-/ปี
█ Tel 0810066690 | EVO VPS | EVO Hosting
VPS Hosting ประสิทธิภาพสูง แรง เร็ว เสถียร
FB : evohostinginth
youtalen
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 55
ออฟไลน์ ออฟไลน์

กระทู้: 1,482



ดูรายละเอียด เว็บไซต์
« ตอบ #15 เมื่อ: 17 ธันวาคม 2018, 10:25:47 »

php 7.2 เช่า host ที่ไหนครับ ที่ผมย้ายเพราะต้อง เขียนโปรเจค Laravel ซึ่งต้องใช้ PHP >= 7.1.3

จิ้มตามลายเซ็นเลยครับ ให้บริการ PHP 5.6 / 7.1-7.2 ครับผม  wanwan003
บันทึกการเข้า

pharaoh_za
สมุนแก๊งเสียว
*

พลังน้ำใจ: 49
ออฟไลน์ ออฟไลน์

กระทู้: 572



ดูรายละเอียด เว็บไซต์
« ตอบ #16 เมื่อ: 17 ธันวาคม 2018, 10:45:11 »

อีกวิธีลองไปใช้ mod sqli อ่าครับ ผมก็เพิ่งแก้ ตัว SMF 2.0.13 กับ php 7.0
บันทึกการเข้า

honghong
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 113
ออฟไลน์ ออฟไลน์

กระทู้: 1,265



ดูรายละเอียด
« ตอบ #17 เมื่อ: 17 ธันวาคม 2018, 11:19:06 »

ถ้าลงใหม่ไม่มีปัญหา

แต่ถ้าย้ายมา มันต้องแก้บางไฟล์ครับ

เพราะ php7 มีบางส่วนที่ตัวเก่าไม่ Support

ใช้พวก mod sqli และก็แก้ในส่วนโค๊ตบางจุด ถ้าจำไม่ผิด ต้องไล่ดู

ผมคิดราคา 1000 เพราะผมเคยเจอปัญหาตอนย้าย

ถ้าสนใจทักหลังไมค์ครับ
บันทึกการเข้า
bosszi
คนรักเสียว
*

พลังน้ำใจ: 11
ออฟไลน์ ออฟไลน์

กระทู้: 143



ดูรายละเอียด เว็บไซต์
« ตอบ #18 เมื่อ: 18 ธันวาคม 2018, 08:32:31 »

ตอนนี้ผมติดตั้งได้แล้วนะครับ ขอบคุณทุกความเห็นจากเพื่อนๆครับ

สาเหตุคือ ตอนติดตั้ง
ห้ามคลิก use UTF-8
ห้ามลง Themes ภาษาไทย
ห้ามติดตั้งภาษาไทย  
จะลงได้ปรกติ ไม่ติด erroe Not Found nginx/html/50x.html อีกเลย ใช้ได้ปรกติ

แต่ปัญหาผมยังไม่จบ SMFเดิมที่ผมมี database เดิมอยู่ มันเป็น UTF-8 ครับ เดี๋ยวลองมั่วดูก่อน ท่านไดมีคำแนะนำ รบกวนบอกด้วยนะครับ ผมไม่เคยเปลียนภาษาใน database


« แก้ไขครั้งสุดท้าย: 18 ธันวาคม 2018, 08:34:22 โดย bosszi » บันทึกการเข้า

nacamoto
Newbie
*

พลังน้ำใจ: 0
ออฟไลน์ ออฟไลน์

กระทู้: 19



ดูรายละเอียด
« ตอบ #19 เมื่อ: 18 ธันวาคม 2018, 08:42:12 »

แบบเดียวกับผมเลยครับ  สุดท้าย ผมคุยกับเจ้าของโฮสต์ เขายอมไปให้ใช้เวอร์ชั่นเก่า แต่จะเสี่ยงโดนเจาะระบบสูง เวอร์ชั่นเก่ามันไม่ปลอดภัย
บันทึกการเข้า
หน้า: [1] 2   ขึ้นบน
พิมพ์