ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น

ThaiSEOBoard.comความรู้ทั่วไปGeneral (ถามคุยวิชาการ IM)ผิดไหมที่ผมพัฒนา AppServ ให้ใช้ฟรี ????
หน้า: 1 [2] 3 4 ... 9   ลงล่าง
พิมพ์
ผู้เขียน หัวข้อ: ผิดไหมที่ผมพัฒนา AppServ ให้ใช้ฟรี ????  (อ่าน 27299 ครั้ง)
0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้
kororo56
Newbie
*

พลังน้ำใจ: 8
ออฟไลน์ ออฟไลน์

กระทู้: 89



ดูรายละเอียด
« ตอบ #20 เมื่อ: 09 พฤษภาคม 2015, 03:27:24 »

 AppServ ถ้าลองไปลง cms หรือ framework รุ่นใหม่ ๆ ไปก็จะเกิด error กับ warning บาน สุดท้ายแล้วก็หันไปใช้ตัวอื่นแทน
บันทึกการเข้า
apples
Newbie
*

พลังน้ำใจ: 12
ออฟไลน์ ออฟไลน์

กระทู้: 24



ดูรายละเอียด
« ตอบ #21 เมื่อ: 09 พฤษภาคม 2015, 03:28:20 »

ผมบอกตรงๆ นะครับ ลูกค้าผมไม่ได้มีแต่ประเทศไทยครับ
มีลูกค้าต่างประเทศเยอะบางคนทำ Embedded Hardware ปริ้นออก Thermal เลย
เค้าไม่ได้มองจุดที่ว่าเก่าหรือใหม่ แต่เค้าใช้เพราะว่าเค้าสามารถทำให้งานของเค้าเดินต่อไปได้
ผมได้ Donate จากต่างประเทศตลอดเวลาผ่าน Paypal  ครับผม ผมไม่ใช่ว่าผมไม่อยากพัฒนาต่อ
แต่ผมทำอยู่ครับทุกวันนี้

แต่..... PHP ยังไม่ Stable อัพจาก 5.2 -> 5.3 ไม่ทันไร 5.4 ยังไม่พอ 5.5 ไม่ต้องอัพละเป็น 5.6 แล้ว
โดยตรงนี้ผมอ้างอิงจาก Linux Debian ที่ผมใช้ Debian 8.0 ออกมาล่าสุดเป็น PHP 5.6 แล้วครับ
ถ้าในฐานะ System Admin ผมอยากให้เข้าใจครับว่าเจอการเปลี่ยนแบบนี้ผมอัพเกรดทันทีได้ไหม
ผมตอบได้เต็มปากเลยผมทำให้ได้เลยไม่เกิน 1 ชม. แต่ คนที่ตายคือใคร ??
คนเขียนโปรแกรมครับ Programmer ตายอย่างเดียว เค้าก็บอกพี่ทำแบบนี้ผมแก้ Code วันนี้ไม่จบครับ
กว่าจะแก้ได้ขอพี่รันระบบเป็น version เดิมก่อนได้ไหมครับ

สุดท้ายเรื่อง Outed Date ไม่ได้เกี่ยวหรอกครับ ผมยืนยัน อยู่ที่คนเลือกใช้
จะใช้ไม่ใช้ก็สุดแล้วแต่ แต่บอกให้หยุดไม่มีใครหยุดครับ ผมในฐานะคนทำแจกฟรี
ผมถึงออกมาพูดได้ หากคุณไปพูดกับ Microsoft บอกห้าม Install Windows XP ต่อไป
เค้าก็ไม่ตอบสนองคุณนะครับ เงียบอย่างเดียว เพราะอะไร ก็เพราะเค้ายังได้เงิน
ได้ในส่วนที่เค้าไม่คิดว่าเค้าหยุดพัฒนาหรือไม่สามารถบังคับคนใช้ Windows ใหม่ได้
นั่นคือเหตุผลจริงๆ ครับ ว่าเค้ายังสามารถมีงานหรือมีเงินจุดนี้ได้

ถึงอยากบอกว่าผมยังไงก็พัฒนาต่อ จุดเปลี่ยน PHP ตอนนี้ดิ่งเหวมาก ลองเขียน PHP 5.4 -> 5.6
บอกเลยครับตายอย่างเดียว ในฐานะที่ผมเป็นนักพัฒนาบางทีต้องเปิดกว้างๆ เปิดยาวๆ
เรื่องโปรแกรมมิ่งไม่ได้จบแค่นี้ มันไปได้อีกยาว แต่บางอย่างก็ต้องอยู่ต่อเพื่อให้ระบบเดินได้

ผมทำแจกผม Indy ผมไม่ได้ปล่อยไวรัส ผมก็จะทำแบบนี้ แล้วผมก็จะพัฒนาต่อไป
ใครใช้ไม่ใช้ เป็นสิทธิส่วนบุคคล ผมไม่ได้สนว่าใครจะคิดยังไงแต่ผมให้ฟรีๆ
สุดท้ายจะอยู่ที่ใครใช้ไม่ใช้ สิทธิใครสิทธิมัน ไม่ใช่มาบอกว่าต้องหยุดนั่นหยุดนี่ครับ
ขอให้เข้าใจด้วยครับผมทำแจกฟรี ผมไม่ได้ผิด แต่ผมทำตามความต้องการที่ผมทำเท่านั้นครับ
บันทึกการเข้า
jirayu
Newbie
*

พลังน้ำใจ: 6
ออฟไลน์ ออฟไลน์

กระทู้: 55



ดูรายละเอียด เว็บไซต์
« ตอบ #22 เมื่อ: 09 พฤษภาคม 2015, 03:54:42 »

สวัสดีครับคุณภาณุพงศ์

ในมุมของผู้ดูแลระบบ  ผมเข้าใจดีครับ  ตัวผมเองก็ดูเซิร์ฟเวอร์เล็กๆ อยู่เช่นกัน (เป็นคลาวด์บน DigitalOcean)
ผมก็พบปัญหาเช่นกันตอนย้ายจาก PHP 5.3 (บน Ubuntu 12.04) มา PHP 5.6 (บน Ubuntu 14.04)
ซึ่งผมก็ต้องตามแก้บั๊กต่อเพื่อให้รันได้ต่อไปบน PHP 5.6 (แต่แก้ไม่มากเท่าตอนเปลี่ยนจาก 5.2 > 5.3 ครับ)

ส่วนในมุมของนักพัฒนา  การเริ่มพัฒนาโดยใช้ PHP เวอร์ชันที่เป็นปัจจุบันนั้นสำคัญครับ  ตรงนี้เราต้องยอมรับว่า
โฮสต์ส่วนใหญ่นั้นใช้ PHP เวอร์ชันใหม่กันหมดแล้ว (แม้แต่ AppServ Hosting เอง) แต่ปัจจุบันผมยังเห็นหลายๆ ท่าน
ยังคงใช้ชุดฟังก์ชันที่โดน deprecated ไปเรียบร้อยแล้ว (เช่นกลุ่ม session_register(); หรือ ereg(); )
ซึ่งเมื่อนำมารันบนโฮสต์ที่ใช้ PHP เวอร์ชันใหม่ (เช่น AppServHosting) จะพบ Deprecate error ยาวเป็นหางว่าว

และฟังก์ชันในกลุ่มที่ deprecated ไปแล้ว  ในอนาคตก็ถูกถอดออกจาก PHP โดยสิ้นเชิงเหมือนกัน (เช่น session_register();
ที่โดนถอดออกไปใน PHP 5.4) ซึ่งนักพัฒนาหลายๆ ท่านไม่ทราบถึงจุดนี้เลย  จนกระทั้งดีพลอยงานลงโฮสต์จริง
จึงแสดง error ออกมา  แล้วค่อยตามหาทางแก้กันอีกต่อ (ยังมีเรื่องของการพัฒนาแบบ OOP อีกด้วยครับ)

ตรงนี้ไม่ได้เป็นความเห็นส่วนตัวนะครับ แต่เป็นสิ่งที่กำลังเกิดขึ้นจริงๆ ณ ตอนนี้

ซึ่งในจุดนี้เป็นจุดที่ผมกังวลมากที่สุดจุดหนึ่งสำหรับนักพัฒนาหน้าใหม่ครับ  และส่วนตัวผมเจอผู้ประสบปัญหาลักษณะนี้บ่อย
จึงเป็นเหตุให้อีเมลไปแจ้่งอย่างที่เห็นไปแล้วครับ

ผมขอย้ำอีกทีว่าผมไม่ได้บังคับให้คุณภาณุพงศ์หยุดเผยแพร่ AppServ แต่อย่างใด  เพียงแต่ขอความร่วมมือให้พิจารณาหยุดเผยแพร่เท่านั้นครับ
ซึ่ง ณ จุดนี้ก็กระจ่างดีแล้วว่าคุณภาณุพงศ์จะไม่หยุดเผยแพร่  และจะพัฒนา AppServ ต่อ (ซึ่งเป็นเรื่องที่น่ายินดีมาก) ก็ขอเป็นกำลังใจให้ครับ
« แก้ไขครั้งสุดท้าย: 09 พฤษภาคม 2015, 04:05:56 โดย jirayu » บันทึกการเข้า

รับข่มขืน WordPress ครับ  ติดต่อมาได้

Twitter: @jirayu
Facebook:  http://on.fb.me/jirayu
Web:  http://jirayu.in.th
apples
Newbie
*

พลังน้ำใจ: 12
ออฟไลน์ ออฟไลน์

กระทู้: 24



ดูรายละเอียด
« ตอบ #23 เมื่อ: 09 พฤษภาคม 2015, 04:21:19 »

สวัสดีครับคุณภาณุพงศ์

ในมุมของผู้ดูแลระบบ  ผมเข้าใจดีครับ  ตัวผมเองก็ดูเซิร์ฟเวอร์เล็กๆ อยู่เช่นกัน (เป็นคลาวด์บน DigitalOcean)
ผมก็พบปัญหาเช่นกันตอนย้ายจาก PHP 5.3 (บน Ubuntu 12.04) มา PHP 5.6 (บน Ubuntu 14.04)
ซึ่งผมก็ต้องตามแก้บั๊กต่อเพื่อให้รันได้ต่อไปบน PHP 5.6 (แต่แก้ไม่มากเท่าตอนเปลี่ยนจาก 5.2 > 5.3 ครับ)

ส่วนในมุมของนักพัฒนา  การเริ่มพัฒนาโดยใช้ PHP เวอร์ชันที่เป็นปัจจุบันนั้นสำคัญครับ  ปัจจุบันผมยังเห็นหลายๆ ท่าน
ยังคงใช้ชุดฟังก์ชันที่โดน deprecated ไปเรียบร้อยแล้ว (เช่นกลุ่ม session_register(); หรือ ereg(); )
ซึ่งเมื่อนำมารันบนโฮสต์ที่ใช้ PHP เวอร์ชันใหม่ (เช่น AppServHosting) จะพบ Deprecate error ยาวเป็นหางว่าว

และฟังก์ชันในกลุ่มที่ deprecated ไปแล้ว  ในอนาคตก็ถูกถอดออกจาก PHP โดยสิ้นเชิงเหมือนกัน (เช่น session_register();
ที่โดนถอดออกไปใน PHP 5.4) ซึ่งนักพัฒนาหลายๆ ท่านไม่ทราบถึงจุดนี้เลย  จนกระทั้งดีพลอยงานลงโฮสต์จริง
จึงแสดง error ออกมา  แล้วค่อยตามหาทางแก้กันอีกต่อ (ยังมีเรื่องของการพัฒนาแบบ OOP อีกด้วยครับ)

ตรงนี้ไม่ได้เป็นความเห็นส่วนตัวนะครับ แต่เป็นสิ่งที่กำลังเกิดขึ้นจริงๆ ณ ตอนนี้

ซึ่งในจุดนี้เป็นจุดที่ผมกังวลมากที่สุดจุดหนึ่งสำหรับนักพัฒนาหน้าใหม่ครับ  และส่วนตัวผมเจอผู้ประสบปัญหาลักษณะนี้บ่อย
จึงเป็นเหตุให้อีเมลไปแจ้่งอย่างที่เห็นไปแล้วครับ

ผมขอย้ำอีกทีว่าผมไม่ได้บังคับให้คุณภาณุพงศ์หยุดเผยแพร่ AppServ แต่อย่างใด  เพียงแต่ขอความร่วมมือให้พิจารณาหยุดเผยแพร่เท่านั้นครับ
ซึ่ง ณ จุดนี้ก็กระจ่างดีแล้วว่าคุณภาณุพงศ์จะไม่หยุดเผยแพร่  และจะพัฒนา AppServ ต่อ (ซึ่งเป็นเรื่องที่น่ายินดีมาก) ก็ขอเป็นกำลังใจให้ครับ


คุณยังยืนยันจุดเดิมว่า ขอความร่วมมือหยุดเผยแพร่ ผมถึงถามว่าผมผิดไหมที่ผมทำ AppServ แจกฟรี ผมก็แจ้งแล้วครับว่าผมพัฒนาต่อ
ยังไม่ถึงจุดที่ผมจะปล่อยออกมา เหตุผลเพราะมี Software ตัวอื่นที่มาทดแทนตัว AppServ version เก่าได้ ซึ่งอยู่ที่คนจะเลือกใช้

ผมก็อธิบายคุณไปแล้วว่ามีหลายอย่างที่คนอื่นใช้อยู่ยังไม่พร้อม เหตุผลเพราะโปรแกรมที่เค้าทำอยู่ยังไม่รองรับ
คุณอย่าใช้เหตุผลของคุณเองในการตัดสินใจ หรือบังคับให้คนอื่นให้ทำตามความต้องการของคุณ อยากให้คุณเข้าใจหน่อยครับ
ว่าหลายๆ คนที่เค้าใช้โปรแกรมผมเค้ามีเหตุผลทำไม่เค้าต้องใช้อยู่ ทำไมเค้ายังไม่สามารถพัฒนาต่อไปได้

ผมว่าคุณทำ Campaign ให้คนทั่วไปหันมาใส่ใช่เรื่อง PHP version ในการพัฒนาดีกว่าครับ อย่างน้อยเค้าจะได้รู้ว่า
ตอนนี้เค้าต้องใช้ PHP version อะไร โดยที่เค้าจะได้ไม่พลาดโหลด Software ที่ PHP version เก่ามาพัฒนาโปรแกรมครับ
ผมถึงบอกว่าผมไม่สามารถหยุดเผยแพร่ AppServ ที่ใช้ PHP 5.2 ได้ครับ หากคนดาวน์โหลดเค้ายังไม่เข้าใจเรื่อง Version ครับ

ที่ผมบอกหรือโพสตรงนี้ผมถึงอยากให้คนอื่นได้รู้ว่า ผมผิดด้วยหรือที่ผมทำแจกฟรี ? อยู่ดีๆ บอกให้ผมหยุดเผยแพร่
ทั้งๆ ที่ผมยังหารายได้จากสิ่งที่ผมพัฒนาอยู่จนถึงวันนี้ได้อยู่เลย Huh?Huh?Huh? ผมก็ทำงานหาเงินเหมือนกันครับ
โปรแกรมแจกฟรีแต่ผมได้ Support ในการช่วยหรือในเรื่องของโปรแกรมที่ผมพัฒนานะครับ แค่มาบอกแบบนี้ก็ไม่เห็นใจกันเลยครับ

บันทึกการเข้า
iamtv6
Newbie
*

พลังน้ำใจ: 12
ออฟไลน์ ออฟไลน์

กระทู้: 57



ดูรายละเอียด
« ตอบ #24 เมื่อ: 09 พฤษภาคม 2015, 04:36:27 »

เมื่อก่อนไม่มี AppServ  พวก Dev ก็ ค่อย ๆ ลง กันตาม Step ครับ
ผมเขียนโปรแกรมมา 15 ปี

จึงทำให้ Dev รุ่นเก่า ๆ ไม่ค่อยพึ่งพาพวก Apperv มากเท่าไร เพราะยุคก่อน ๆ ไม่มี Server ให้คุณใช้งานหลากหลายแบบนี้ครับ


ตั้งแต่เขียนสมัยเป็นลูกจ้าง เขียนให้ลูกค้า จนถึงเขียนให้ธุรกิจตัวเอง
ผมว่าปัญหานี้ ไม่ได้เกี่ยวกับ Appserv เลยครับ
มันอยู่อยู่ โปรแกรมเมอร์ครับ ว่า มีความสามารถในการแก้ปัญหาได้ดีแค่ไหน ในการ Config ให้ระบบ มันเข้ากันได้ครับ
ซึ่งถ้าคุณมีลูกค้าหลาย ๆ แบบ คุณก็ต้องยอมรับว่า ในแต่ละ ระบบ มันไม่เหมือนกัน

ผมขอยกตัวอย่างนะครับ บางครั้ง Server ของลูกค้าเก่าหรือทำงานอยู่ในระบบเก่า ๆ ที่เราพัฒนานานแล้ว
บางครั้งเขาอยากจะ update  หรือไปเจอคนแนะนำว่าระบบเก่าแล้ว ควรจะอัปเดท ก็จะมีโปรแกรมเมอร์ มือใหม่ ไร้ประสบการ
ไปตามอัปเดทเวอร์ชั่นให้ สุดท้ายระบบมันก็รวน

ผมก็ต้องมานั่งอธิบายว่า อะไรมันไม่เข้ากัน ถ้าจะให้มันเข้ากันทำงานได้ดีพี่ต้องแก้ตั้งแต่ นู้นนี้ นั้น และ เมื่อแก้ไขมาก
มันก็จำเป็นต้องมีค่าใช้จ่าย ถ้าคุณไม่พร้อมก็ต้องยอมใช้อันเก่าเพื่อให้ธุรกิจคุณดำเนินไปได้


...............  ทำไมยังมีคนใช้ OS เก่า ๆ กับคอมส่วนตัว ...............
เพราะเขาไม่อยาก อัปเกรด และบางทีงานในเครื่องเขาเยอะ Config ไว้เพียบขี้เกียจมา Config บ่อย ๆ

ลองไปดูหน้าจอธนาคารกรุงเทพครับว่าโบราณแค่ไหน


สุดท้ายสั้น ๆ ใช้หรือไม่ใช้ โปรแกรมเมอร์เป็นคนเลือกครับ คือถ้า Appserv ใช้ไม่ได้กับงานคุณ หรือไม่เข้ากับ CMS ที่คุณใช้งาน
คุณก็ต้องเลือก
1.เขียน CMS มาใช้งานเอง
หรือ
2.Config แก้ไขให้ผ่าน

ส่วนกังวลนักพัฒนาหน้าใหม่ ผมว่าอย่าไปกังวลเลยครับ
ถ้าเขาทำไม่ได้แก้ปัญหาไม่ได้ ก็ให้เป็นหน้าใหม่ต่อไป หรือไม่ ก็ไปหากินอย่างอื่น อาจจะรวยและไม่ต้องปวดหัวครับ

"เลือกให้เหมาะกับเราครับ"
บันทึกการเข้า
yen032
Verified Seller
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 254
ออฟไลน์ ออฟไลน์

กระทู้: 2,738



ดูรายละเอียด
« ตอบ #25 เมื่อ: 09 พฤษภาคม 2015, 05:36:52 »

ท่านนี้เป็นคนก่อกำเนิด appserv หรือเนี้ย

ชื่นชมครับ สุดยอด อยู่กันมาตั้งแต่หัดทำเว็บ
บันทึกการเข้า
Tanat1
ก๊วนเสียว
*

พลังน้ำใจ: 12
ออฟไลน์ ออฟไลน์

กระทู้: 275



ดูรายละเอียด เว็บไซต์
« ตอบ #26 เมื่อ: 09 พฤษภาคม 2015, 06:15:24 »

ถ้าไม่มี Appserv นี้โปรเจคของผมนี่ไม่จบแน่ๆ ทำต่อไปนะครับ

บันทึกการเข้า

1ZAA
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 1334
ออฟไลน์ ออฟไลน์

กระทู้: 3,548



ดูรายละเอียด เว็บไซต์
« ตอบ #27 เมื่อ: 09 พฤษภาคม 2015, 07:02:27 »

เยี่ยมยอดมากครับ ทำต่อไป
บันทึกการเข้า

ptteppawong
Verified Seller
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 316
ออฟไลน์ ออฟไลน์

กระทู้: 4,786



ดูรายละเอียด
« ตอบ #28 เมื่อ: 09 พฤษภาคม 2015, 07:15:39 »

ขอนอกเรื่องหน่อยครับ  ผมว่าผมเคยไปอ่านความรู้เพิ่มเติมจากบล็อกเค้านะ    www.jirayu.in.th    ใช่คนเดียวกันเหรอเปล่า....

บล็อกท่านสุดยอดมากเลยครับ  ความรู้ดี ๆ เพียบ

แต่ก็เอาใจช่วยเจ้าของกระทู้ด้วยนะ เห็นใจคนพัฒนาเหมือนกัน......
บันทึกการเข้า
kondam
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 522
ออฟไลน์ ออฟไลน์

กระทู้: 6,146



ดูรายละเอียด เว็บไซต์
« ตอบ #29 เมื่อ: 09 พฤษภาคม 2015, 07:18:11 »

สมัยเรียนผมก็ใช้ appserv  ครับ  wanwan017
บันทึกการเข้า

ขอแนะนำ : wanwan034

1. จดโดเมน ต่ออายุ godaddy ลด 40% ถูกที่สุดในตอนนี้! คลิก

2.จดโดเมน + private 8.88$ [namecheap]   คลิก

3.แนะนำคลาวด์โฮสติ้งไทย ที่ผมใช้อยู่ [Thaidata]   คลิก
dingdong8002
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 543
ออฟไลน์ ออฟไลน์

กระทู้: 4,820



ดูรายละเอียด เว็บไซต์
« ตอบ #30 เมื่อ: 09 พฤษภาคม 2015, 07:23:31 »

Appserv เคยใช้มาหลายปีก่อนนู้นนนน สมัยลองทำเว็บเองใหม่ๆ ยังไม่มีตังค์เช่าโฮสเลย
ยังไงก็ดูสถานการณ์โลก สถานการณ์คน  สถานการณ์อารมณ์ กันต่อไปนะครับ คิดถึงคนอื่นให้เหมือนกับคิดถึงตัวเรา แล้วอะไรๆจะดีขึ้น  wanwan013
« แก้ไขครั้งสุดท้าย: 09 พฤษภาคม 2015, 07:25:04 โดย dingdong8002 » บันทึกการเข้า

โฮสเจ้านี้ ดีและถูกที่สุดแล้ว ล่มยาก ไม่จุกจิก
แชร์โฮส เริ่มที่ 277บาท/ปี, VPS เริ่มที่ 290บาท/เดือน
เซิร์ฟเวอร์มีทั้ง TH,SG,US

สนใจ ▶︎ CLICK ◀︎
Keyvvord
Newbie
*

พลังน้ำใจ: 21
ออฟไลน์ ออฟไลน์

กระทู้: 65



ดูรายละเอียด
« ตอบ #31 เมื่อ: 09 พฤษภาคม 2015, 07:45:48 »

ขอเป็นกำลังใจให้คุณภาณุพงศ์ครับ อย่าไปสนใจเลยครับ

ถ้าในอดีตไม่มีโปรแกรม AppServ ท่านที่หวังดีลองคิดดูโปรแกรมเมอร์จะลำบากขนาดไหน
ในเมื่อปัจจุบันโปรแกรม AppServ ไม่ได้พัฒนาต่อแล้ว ท่านก็ควรค้นหาในสิ่งที่ดีกว่า หรือพัฒนาขึ้นใหม่เอง
ที่ผ่านมาคุณภาณุพงศ์แจกให้ใช้ฟรี ซึ่งก็ใช้กันทั่วโลก มีรายได้จากการนำโปรแกรมไปใช้กันจำนวนมาก

เป็นกำลังใจครับ

บันทึกการเข้า
BakKheab
สมุนแก๊งเสียว
*

พลังน้ำใจ: 65
ออฟไลน์ ออฟไลน์

กระทู้: 725



ดูรายละเอียด
« ตอบ #32 เมื่อ: 09 พฤษภาคม 2015, 07:52:14 »

เท่าที่อ่านๆดู ไม่เชิงขอความร่วมมือซักเท่าไหร่ เหมือนเป็นการบังคับซะมากกว่า
พี่เค้าเป็นเจ้าของ เป็นคนพัฒนา จะอะไรยังไงก็สุดแล้วแต่พี่เขาเถอะครับ
ถ้าคุณใช้แล้วไม่เวิร์ค คุณก็ไม่ใช้ ในเมื่อเราก็มีทางเลือกอื่นอยู่แล้ว ก็ไม่ต้องซีเครียดครับ
ส่วน Programmer คนอื่นๆเขาก็จะเลือกของเขาเองแหละครับ ว่าเขาจะใช้หรือไม่ใช้ ถ้ามันดีเขาก็ใช้ ถ้ามันไม่ดีแล้วเขาจะใช้ทำไม อย่ากังวลใจไปเลยครับ
ถึงจะบอกให้พี่เขาหยุดเผยแพร่ แต่ผมว่ายังไงๆก็มีคนเอามาแจกอีกอยู่ดี จะให้หายไปเหมือนที่คิดไว้ คงเป็นไปไม่ได้หรอกครับ

ใจเขาใจเราครับ เรามีเหตุผล คนอื่นๆเขาก็มีเหตุผลเหมือนกัน อย่าเอาความคิดตัวเองเป็นที่ตั้ง
จะอยู่ในสังคม มันไม่มีอะไรที่ได้ดั่งใจไปซะทุกอย่างหรอกครับ
ถึงแม้ว่า "ไม่อยากจะขัดใจตัวเอง" ก็ต้องยอมหย่อนๆบ้าง เพื่อความสงบสุขของบ้านเมือง.......
 wanwan007  wanwan003  wanwan019  wanwan013 
บันทึกการเข้า
wich2009
สมุนแก๊งเสียว
*

พลังน้ำใจ: 42
ออฟไลน์ ออฟไลน์

กระทู้: 779



ดูรายละเอียด เว็บไซต์
« ตอบ #33 เมื่อ: 09 พฤษภาคม 2015, 08:00:54 »

ยังไงก็ต้องขอบคุณ  AppServ
ที่ทำให้ผมมีของฟรีใช้
จนสามารถทำเว็บได้
ใช้ฐานข้อมูลเป็น
และที่สำคัญ เป็นของฟรี
ที่เกิดจากผีมือคนไทย
เยี่ยมจริงๆ ครับ

เป็นกำลังใจให้ครับ
บันทึกการเข้า

l3master
สมุนแก๊งเสียว
*

พลังน้ำใจ: 106
ออฟไลน์ ออฟไลน์

กระทู้: 826



ดูรายละเอียด เว็บไซต์
« ตอบ #34 เมื่อ: 09 พฤษภาคม 2015, 08:15:31 »

ผมว่าทั้งสองท่านก็เจตนาดีทุกท่านแหละครับ
เพียงแต่มีความคิดเห็นที่แตกต่างกันเท่านั้น
ส่วนท่านที่พัฒนา ก็อยากได้รับฟังความเห็นหลายๆด้านด้วยนะครับ
สู้ๆ อย่าเพิ่งมาม่ากัน  wanwan003
บันทึกการเข้า



บริการรับทำ Facebook Chat bot
ถาม-ตอบแทนแอดมินได้ เชื่อมต่อ API หรือฐานข้อมูลก็ได้ แถมฟรี!ระบบออโต้คอมเมนท์ และฟีเจอร์ใหม่ๆตลอด คลิ๊ก https://goo.gl/H2otJi

รับทำแชทบอท OPDEV.MEN
สมหยัด
ก๊วนเสียว
*

พลังน้ำใจ: 64
ออฟไลน์ ออฟไลน์

กระทู้: 262



ดูรายละเอียด
« ตอบ #35 เมื่อ: 09 พฤษภาคม 2015, 08:17:25 »

อย่างไรก็แล้วแต่ คุณภาณุพงศ์ เป็นทั้งพัฒนาและผู้ให้บริการที่ดีมากๆคนนึงเลย
อะไรที่เป็นผลดีกับสังคม ทำต่อเถอะครับ ความเห็นจากผู้ใช้ มีหลายแบบมากมาย ทั้งดีไม่ดี
ยึดมั่นในสิ่งที่ทำอยู่ ยึดมั่นในความ Indy ของคุณ คุณมีเหตุผลที่จะทำหรือไม่ทำอะไร เป็นสิทธิ์ของคุณเต็มที่ครับ
มีนักพัฒนามือใหม่ เด็กนักเรียน ผู้ที่เริ่มศึกษาได้ประโยชน์จากสิ่งที่คุณทำเป็นอย่างมาก ผมก็เป็นหนึ่งในนั้น

เป็นกำลังใจให้อย่างมากครับ
 wanwan003
บันทึกการเข้า
narincr
คนรักเสียว
*

พลังน้ำใจ: 20
ออฟไลน์ ออฟไลน์

กระทู้: 197



ดูรายละเอียด เว็บไซต์
« ตอบ #36 เมื่อ: 09 พฤษภาคม 2015, 09:03:37 »

เมื่อ ผมอายุ 15 ปีที่แล้ว ผมเริ่มเขียน HTML และมาเริ่ม PHP ด้วย Appserv ของพี่นี่แหล่ะครับ

และยังเป็นลูกค้าของ appservhosting.com ที่นิ่ง ๆ และดีมาตลอดด้วยครับ ปัจจุบันก้ยังใช้อยู่
appserv เป็นโปรแกรมแรกที่ผมใช้ลง และรู้สึกสะดวกมาก ๆ ในการติดตั้งและทดสอบโปรแกรม และทุกวันนี้ก็ยังใช้งานในเครื่องเดิม PC เครื่องแรกในชีวิตก็ยังใช้โปรแกรมนี้อยู่ เพราะลงในสเปคต่ำ ๆ ได้ปกติครับ
ต่อมา ผมอัพเกรดซื้อคอม PC เครื่องใหม่ ผมก็มาใช้ IIS + Web Server ลง mysql เอง microsoft sql server เอง แต่เครื่องเดิมก็ยังอยู่เหมือนเดิมครับ เพราะนักศึกษาก็ยังใช้ Appserv อยู่ พอผมจะส่งงานผมก็เอาไปรันในเครื่องเดิมก่อน ดูว่าจะใช้ได้ไหม

ตอนนี้ ผมก็ซื้อ Macbook Pro ใหม่อีกตัว และลง XAMPP และเขียน PHP อยู่เช่นเดิม ซึ่งในการเขียนโปรแกรม ผมก็ใช้งานทั้ง 3 ตัวครับ ทั้ง Appserv 2.5.10 + IIS 8.0 + XAMPP ครับ
ผมว่าอยู่ที่คนเลือกใช้งานมากกว่า ตอนนี้ผมได้เป็นโปรแกรมเมอร์เต็มตัวแล้ว ผมก็นึกย้อนไปว่า เมื่อ 10 ปีที่แล้วที่ผมก็ใช้ Appserv ของคุณเปิ้ล ผมก็รู้สึกยินดีที่พี่ร่วมเป็นก้าวหนึ่งให้ผมมีวันนี้ได้ครับ

แต่ผมก็ยังไม่ได้ ทิ้งไปนะครับ ถ้าพี่อัพเดทผมก็จะอัพคอมเครื่องนั้นขึ้นต่อไป อัพเวอร์ชั่นต่ออยู่แล้วครับ
ส่วนมุมมองของการใช้งาน

ถ้าเราเขียนโปรแกรมขึ้นมาอันนึง แล้วเราแจกฟรีให้เขาไป ถ้ามี Bug เขาก็บอกว่าโปรแกรมไม่ดี ก็เลิกใช้ ใช่ไหมครับ แต่เราไม่มีสิทธิ์ในการบอกให้เขาทำอะไรให้เรา เพราะแจกฟรี เต็มที่ได้แค่แนะนำ และก็มีเขียนอธิบายอยู่แล้วนะครับว่า เป็น PHP Version อะไร , Mysql Version ไหน ถ้าคนรู้จักอ่านก็เข้าใจได้เลยนะครับ Wordpress ยังบอกเลยครับว่า Requirement ของ Script ต้องการอะไรบ้าง เราก็จะต้องดูให้ดีก่อนครับ
ถ้าเราขายโปรแกรมขึ้นมาตัวนึง เรายังกำหนดขอบเขตเลยครับว่า แก้ไขได้ไหม เขียนเพิ่มได้ไหม หรือ การพัฒนาจะไปทางไหน ราคาเท่าไร สมราคาที่ลูกค้าซื้อไปหรือไม่ ถ้าซื้อค่อยมาโวยดีกว่าครับ

ในส่วนของ Appserv ขึ้นอยู่ในข้อแรกครับ คนใช้ก็ต้องดูด้วย เราซื้อของยังต้องเลือกเลยครับ เราเลือกให้เหมาะกับตัวเราเองดีกว่าไหมครับ เปลี่ยนที่ตัวเองดีกว่า ก่อนที่จะเปลี่ยนอะไร จะเปลี่ยนโลก ก็ต้องเริ่มที่ตัวเราก่อนอยู่แล้วครับ

พี่เปิ้ลไม่ผิดแน่นอนครับ และไม่ต้องทำตามคำแนะนำด้วย ตอนนี้ 5.6 ของ พี่เปิ้ลก็มีแล้วนิครับ ถ้าเริ่มใหม่ ผมก็ไปใช้ PHP5.6 เลยดีกว่าไหมครับ
ขอให้มีเวอร์ชั่นใหม่เร็ว ๆ นะครับ ผมติดตามแน่นอนครับ

ขอบคุณครับ
บันทึกการเข้า

รับทำเว็บไซท์ แก้ไข Script CMS  โปรเจ็คนักศึกษา Script PHP ทุกชนิด รับงานเร่ง งานด่วน รับภายใน 3-5 วัน โทรหรือ Line มาคุยกันได้ครับ
DO-PHP.COM , DO-PHP.COM , DO-PHP.COM
Mobile : 092-1064587 , Line : narin.php Email : narin.cr@gmail.com
treehost
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 99
ออฟไลน์ ออฟไลน์

กระทู้: 2,028



ดูรายละเอียด เว็บไซต์
« ตอบ #37 เมื่อ: 09 พฤษภาคม 2015, 09:12:33 »

ทุกวันนี้ผมก็ใช้ Appserv ครับ  เพราะขนาดเบากว่า Xampp  ใช้งานง่ายกว่า  ไม่ต้องไปเซ็ท pass root  mySQL ทีหลัง น่าเบื่อครับ  wanwan020 wanwan020 wanwan020
บันทึกการเข้า

|(。◕‿‿◕。)| VPS SSD Raid-5 จัดโปรใจปล้ำ!.. ลด 20% แถมแรม 4GB ฟรี เริ่มต้นเพียง 700บาท
|(。◕‿‿◕。)| Line: @airwave |  ihotVPS
PowerEXP
Newbie
*

พลังน้ำใจ: 1
ออฟไลน์ ออฟไลน์

กระทู้: 9



ดูรายละเอียด
« ตอบ #38 เมื่อ: 09 พฤษภาคม 2015, 09:27:05 »

เท่าที่ผมรู้จักในโลกนี้คนที่เป็นนักพัฒนาไม่ว่าจะเป็น App หรือ Service ไม่ว่าจะฟรีหรือเสียเงินเมื่อแอฟเขาเก่าหรือมีช่องโหว่ เขาต้องประกาศอัพเดทหรือแจ้งเตือนให้หยุดดาวน์โหลด นี่คือจริยธรรมในอาชีพครับ ยิ่งคนโหลดเยอะยิ่งต้องรีบแจ้งหรือแก้ไข เพราะมันมีผลกระทบมากมายในวงกว้าง

ผมเชื่อว่ามีหลายคนโดนสอนโดนบอกกันมาว่าให้ใช้อันนี้ ใช้แบบหลับหูหลับตา เพราะไม่มีความรู้ในเชิงลึก สุดท้ายถ้าธุรกิจเขาได้รับความเสียหาย โดนขโมยข้อมูล โดนลบข้อมูล โดนโจมตี และโดน Hack ในรูปแบบต่างๆ เพราะความไม่รู้ของเขา เพราะคุณไม่แจ้งเขา คุณว่ามันถูกต้องไหมละครับ

ผมเชื่อว่าคนที่ส่งเมลมาเขาหวังดีครับ  ผมเข้าใจว่าคุณก็ภูมิในในผลงานตัวนี้มาก ที่สำคัญคือคุณมีจุดประสงค์ที่ดี แจกจ่ายให้ใช้ฟรี และผมไม่ได้อคติใดๆทั้งสิ้นนะครับ ผมก็เคยใช้ Appserv เช่นกันเมื่อ 7-8 ปีก่อน แต่อยากให้ใจเย็นและลองมองหลายๆมุมครับ
บันทึกการเข้า
x-script
หัวหน้าแก๊งเสียว
*

พลังน้ำใจ: 140
ออฟไลน์ ออฟไลน์

กระทู้: 1,929



ดูรายละเอียด
« ตอบ #39 เมื่อ: 09 พฤษภาคม 2015, 09:35:02 »

ผมว่าคุณโดนเกรียนเล่นงานแล้ว ^^
บันทึกการเข้า
หน้า: 1 [2] 3 4 ... 9   ขึ้นบน
พิมพ์