ยินดีต้อนรับคุณ, บุคคลทั่วไป กรุณา เข้าสู่ระบบ หรือ ลงทะเบียน

เข้าสู่ระบบด้วยชื่อผู้ใช้ รหัสผ่าน และระยะเวลาในเซสชั่น

ThaiSEOBoard.comพัฒนาเว็บไซต์Programmingรบกวนด้วยครับ Notice: SSI.php ไม่สามารถโหลด session ได้ !
หน้า: [1]   ลงล่าง
พิมพ์
ผู้เขียน หัวข้อ: รบกวนด้วยครับ Notice: SSI.php ไม่สามารถโหลด session ได้ !  (อ่าน 972 ครั้ง)
0 สมาชิก และ 1 บุคคลทั่วไป กำลังดูหัวข้อนี้
chiangrai108
สมุนแก๊งเสียว
*

พลังน้ำใจ: 34
ออฟไลน์ ออฟไลน์

กระทู้: 542



ดูรายละเอียด
« เมื่อ: 25 เมษายน 2012, 23:57:15 »

พอดีผมดึงกระทู้จาก SMF มาใส่ที่หน้าแรกของเว็บไซต์ ปรากฏว่ามันขึ้น ข้อความนี้มาครับ  Tongue

Notice: SSI.php ไม่สามารถโหลด session ได้! นี่อาจทำให้คุณมีปัญหากับการออกจากระบบและฟังก์ชั่นอื่นๆ - กรุณาตรวจสอบว่าคุณได้ include ไฟล์ SSI.php ในบรรทัดแรกของ script เว็บไซต์ของคุณ in /home/www/virtual/xxx.com/board/htdocs/SSI.php on line 170

เลยอยากจะรบกวนโปรแกรมเมอร์ ช่วยดูให้ด้วยครับผม

ขอบคุณมากๆครับ  wanwan017
« แก้ไขครั้งสุดท้าย: 29 เมษายน 2012, 11:14:24 โดย chiangrai108 » บันทึกการเข้า
tonotech
ก๊วนเสียว
*

พลังน้ำใจ: 29
ออฟไลน์ ออฟไลน์

กระทู้: 338



ดูรายละเอียด เว็บไซต์
« ตอบ #1 เมื่อ: 26 เมษายน 2012, 00:06:32 »

ย้ายคำสั่ง include "board/SSI.php" ไปไว้บรรทัดแรกสุดครับ
บันทึกการเข้า

ร้านไทยแสตมป์   แสตมป์ไทย แสตมป์ไต้หวัน แสตมป์จีน และแสตมป์ต่างประเทศอื่นๆ เชิญแวะชมได้ครับ

UD Seed จำหน่ายเมล็ดพันธุ์ผักซอง ปลีก-ส่ง ขาย PayPal $1=30.70 บาท มีเข้ามาเรื่อยๆ สนใจ PM สอบถามได้ครับ
chiangrai108
สมุนแก๊งเสียว
*

พลังน้ำใจ: 34
ออฟไลน์ ออฟไลน์

กระทู้: 542



ดูรายละเอียด
« ตอบ #2 เมื่อ: 26 เมษายน 2012, 00:35:23 »

ย้ายคำสั่ง include "board/SSI.php" ไปไว้บรรทัดแรกสุดครับ


คำสั่ง include "board/SSI.php" ผมหาไม่เจออะครับ

ผมใช้โค๊ดนี้ครับ
โค๊ด:
<?php require("/home/00000/public_html/webboard/SSI.php"); ?>
<html>
<head>
<meta http-equiv="Content-Language" content="th">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="keywords" content="..">
<title>..</title>
<link href="nknfe.css" rel="stylesheet" type="text/css">
<style type="text/css">
<!--
body,td,th,tr,iframe {
        font-family: Verdana, Arial, Helvetica, sans-serif;
        font-size: 11px;
        color: #595959;
.style23 {
        font-size: 12px;
        font-weight: bold;
}
.style2 {font-size: 12px}
-->
</style>
<script type="text/JavaScript">
<!--
function MM_openBrWindow(theURL,winName,features) { //v2.0
  window.open(theURL,winName,features);
}

function MM_displayStatusMsg(msgStr) { //v1.0
  status=msgStr;
  document.MM_returnValue = true;
}
//-->
</script>
</head>
<body bgcolor="#F6F4F5" leftmargin="0" topmargin="0" marginwidth="0" marginheight="0">
<table width="100%" border="0" cellspacing="2" cellpadding="2">
  <tr>
    <td target="_self"><?php ssi_welcome(); ?></td>
  </tr>
</table>

<table width="99%">
  <tr>
    <td width="35%" class="style2"><div align="right">20  โพสล่าสุด จากกระดานสนทนา</div></td>
  </tr>
</table>

<table width="100%" border="0" cellpadding="2" cellspacing="2">
  
  <tr>
    <td target="_self"><div align="center">
      <?php ssi_recentTopics(20); ?>
    </div></td>
  </tr>
</table>
<br>
<table width="100%" border="0" cellspacing="2" cellpadding="2">
  <tr>
    <td target="_self"><?php ssi_logOnline(); ?></td>
  </tr>
</table>
</body>
</html>

แล้วผมก็ใช้ iframe ดึงไปหน้าแรก ครับ

โค๊ด:
<iframe src="http://xxxx.com/showtopics.php" name="newtopics" frameBorder="0" width="965" height="500" scrolling="no"></iframe>

พอดีผมทำตามที่นี่อะครับ วิธีดึงกระทู้ล่าสุดมาแสดงที่หน้าแรกของเว็บ

ขอบคุณครับ รบกวนด้วยครับ wanwan017
« แก้ไขครั้งสุดท้าย: 29 เมษายน 2012, 11:14:05 โดย chiangrai108 » บันทึกการเข้า
sunkoster
เจ้าพ่อบอร์ดเสียว
*

พลังน้ำใจ: 46
ออฟไลน์ ออฟไลน์

กระทู้: 4,071



ดูรายละเอียด เว็บไซต์
« ตอบ #3 เมื่อ: 26 เมษายน 2012, 00:42:37 »


ลองแก้ <?php require("/home/00000/public_html/webboard/SSI.php"); ?>
เป็น require_once(dirname(__FILE__) . '/SSI.php');
« แก้ไขครั้งสุดท้าย: 26 เมษายน 2012, 00:44:28 โดย sunkoster » บันทึกการเข้า

chiangrai108
สมุนแก๊งเสียว
*

พลังน้ำใจ: 34
ออฟไลน์ ออฟไลน์

กระทู้: 542



ดูรายละเอียด
« ตอบ #4 เมื่อ: 26 เมษายน 2012, 14:00:53 »


ลองแก้ <?php require("/home/00000/public_html/webboard/SSI.php"); ?>
เป็น require_once(dirname(__FILE__) . '/SSI.php');


ยังไม่ได้เหมือนเดิมครับ ท่าน

ผมลองเข้าไปดูหลายๆเว็บเจอปัญหาเหมือนกันเยอะมากๆเลยครับ
บันทึกการเข้า
หน้า: [1]   ขึ้นบน
พิมพ์